This can be annoying. Firefox will not play Adobe Flash content and will instead display the error ‘Fix Firefox has prevented the outdated plugin “Adobe Flash” from running’. While you can click “Allow…” button to temporarily (or permanently) allow it, it’s strongly recommended that you don’t do it. Because the outdated Flash plugin in vulnerable and can pose security threats. So what should you do? Simple! Go ahead and update the plugin. It’s also advisable to check for other plugins to see if updates are available and install them if they are. Here is a screenshot of the error message:

firefox-block-adobe-flash

How to fix this error

Download and install the latest version of Adobe Flash from here.



Check for updates of other Firefox plugins: Check from this link

After you have downloaded and installed the updates, restart your browser. The error should go away now.